我發現,作業系統的版本如果不同,安裝許多軟體都會有不同的結果,尤其是像ffmpeg這一類行之有年,而且使用到非常多程式庫的程式更是如此。只要作業系統的版本有一些不同,往往就會招致安裝失敗的下場。所以,在本篇文章中所使用的作業系統版本,列示如下:

$uname -a
Linux cb-centos6 2.6.32-573.3.1.el6.x86_64 #1 SMP Thu Aug 13 22:55:16 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
$ cat /etc/redhat-release 
CentOS release 6.7 (Final)

如果你的作業系統版本不同,請自行斟酌是否使用。上述的環境是直接使用Google Could Compute Engine的VM Images==>CentOS 6.7,照著這個網址:https://trac.ffmpeg.org/wiki/CompilationGuide/Centos所提供的安裝步驟,可以完全無誤的地進行安裝的動作。在安裝完畢之後,我們的系統中就會有ffmpeg,ffprobe, ffserver, lame, and x264等可以使用了。

(78)